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Adobe Photoshop includes a powerful
set of cloning tools that make retouching
photographs easy and intuitive. Thanks
to the underlying technology supporting
these features, even touchups of the
human face appear so lifelike and
natural that it is difficult to detect that
a photograph has been altered.
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3 Retouching and Repairing
Lesson overview
In this lesson, you’ll learn how to do the following:

Licensed by
Hal Peterson

• Use the Clone Stamp tool to eliminate an unwanted part of an image.
• Use the Spot Healing Brush tool to repair part of an image.
• Use the Healing Brush and Patch tools to blend in corrections.
• Make corrections on a duplicate layer and adjust it for a natural look.
• Backtrack within your work session using the History palette.
• Use the History brush to partially restore an image to a previous state.
• Use snapshots to preserve earlier states of your work and to compare
alternative treatments of the image.
This lesson will take about 45 minutes to complete. If needed, remove the
previous lesson folder from your hard drive, and copy the Lesson03 folder
onto it. As you work on this lesson, you’ll preserve the start files. If you
need to restore the start files, copy them from the Adobe Photoshop CS3
Classroom in a Book CD.

Getting started
In this lesson, you’ll work on three separate projects, editing three
different photographs. Each of them employs the different retouching
tools in unique ways, so you’ll explore the strengths and special uses of
the various tools.
You’ll start by previewing the three images that you’ll retouch in this lesson.
1 Launch Adobe Photoshop, holding down Ctrl+Alt+Shift (Windows)
or Command+Option+Shift (Mac OS) to restore the default preferences.
(See “Restoring default preferences” on page 6.)
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2 When prompted, click Yes to confirm that you want to reset preferences, and Close to
close the Welcome Screen.
3 Click the Go To Bridge button ( ) in the tool options bar to open Adobe Bridge.
4 In the Favorites panel, click Lessons, then double-click the Lesson03 folder
thumbnail to preview its contents, namely, the Lesson03 Start and End files, with the
letters A, B, and C.

• The first project is a photograph of a Japanese stone garden lantern with
semitransparent text superimposed on the foreground. You will repair a torn-off
corner of the scanned image and remove some distracting areas where sprinklers in
the grass appear in the background.
• The second project shows a rock climber scaling a stone wall. You will clean up the
wall beside the climber to remove some graffiti and scars from old bolt holes on the
surface of the rock.
• The third project is a portrait of a man. You will retouch the portrait to remove some
of the fine lines from the man’s forehead and around his eyes.
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5 When you have finished previewing the files, double-click the 03A_Start.psd file
thumbnail to open the image in Photoshop.
6 If necessary, in Photoshop, zoom in to 100% and resize the image window so that you
can see the entire image.
7 Choose File > Save As, rename the file 03A_Working.psd, and click Save. This
preserves the original start file.

Repairing areas with the Clone Stamp tool
The Clone Stamp tool uses pixels from one area of an image to replace the pixels in
another part of the image. Using this tool, you can not only remove unwanted objects
from your images, but you can also fill in missing areas in photographs you scan from
damaged originals.
You’ll start by filling in the torn corner of the photograph with cloned grass from
another area of the picture.
1 Select the Clone Stamp tool ( ) in the toolbox.
2 In the tool options bar, open the Brush Preset pop-up menu in the options bar and
select a large-sized brush with a soft edge, such as Soft Round 75. Then, make sure that
the Sample Aligned option is selected.

3 Move the Clone Stamp tool pointer to the center of the image so that it is at the same
level as the top edge of the torn corner and over grass. Then, hold down Alt (Windows)
or Option (Mac OS) so that the pointer appears as target cross hairs, and click to start
the sampling at that part of the image. Release the Alt or Option key.
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4 Starting at the top edge of the torn corner of the photograph, drag the Clone Stamp
tool over a small area at the top of the torn area of the image.

Notice the cross hairs that appear to the right of the Clone Stamp tool in the image
window. The cross hairs indicate the source area of the image that the Clone Stamp tool
is reproducing as you drag.
5 Release the mouse button and move the pointer to another area of the missing
corner, and then start dragging again.
Notice that the cross hairs reappear not at the original source spot that you selected in
Step 3, but at the same spatial relationship to the Clone Stamp tool pointer that they had
when you made the first stroke. This happens because you selected the Sample Aligned
option, which resets the cross hairs at that position regardless of the position of the
Clone Stamp tool.
Note: When the Sample Aligned option is not selected and you make multiple brush
strokes, the cross hairs and the brush maintain the same spatial relationship (distance and
direction) that they had when you started your first brush stroke, regardless of the location
of the original sample site.
6 Continue cloning the grass until the entire missing corner of the image is filled in.
If necessary to help make the grass appear to blend in naturally with the rest of the
image, you can adjust your cloning by resetting the sample area (as you did in Step 3)
and recloning. Or, you can try deselecting the Sample Aligned option and cloning again.
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7 When you are satisfied with the appearance of the grass, choose File > Save.

Using the Spot Healing Brush tool
The next task to be done is to remove the sprinkler heads from the right side and upper
left of the image. You could do this with the Clone Stamp tool, but instead you’ll use
another technique. You’ll use the Spot Healing Brush to paint out the sprinklers.

Painting with the Spot Healing Brush
The Spot Healing Brush tool quickly removes blemishes and other imperfections from
photos. It works similarly to the Healing Brush: It paints with sampled pixels from an
image or pattern and matches the texture, lighting, transparency, and shading of the
sampled pixels to the pixels being healed. But unlike the Healing Brush (which you’ll
use later in this lesson), the Spot Healing Brush doesn’t require you to specify a sample
spot. It automatically samples from around the retouched area.
The Spot Healing Brush is excellent for retouching blemishes in portraits, but it will also
work nicely in this image of the sprinklers in the grass, because the grass has a uniform,
muted appearance across the top of the image.
1 In the toolbox, select the Spot Healing Brush tool ( ).
2 In the tool options bar, click the Brush Preset pop-up menu and make the brush
larger, about 30 pixels in diameter.
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3 Drag with the Spot Healing Brush in the image window across the sprinkler head on
the right side of the image, and then repeat with the left sprinkler. You can use one stroke
or successive strokes; paint until you are satisfied with the results. As you drag, the stroke
at first appears dark gray, but when you release the mouse, the painted area is “healed.”

You’ll add just one final tweak to this retouching project, and then you’ll be finished.
4 In the Layers palette, click to the left of the Yukimi layer in the Show Visibility
column to place an eye icon ( ) so that the text is visible in the image window.

5 Choose File > Save, and then close the 03A_Working.psd file.

Using the Healing Brush and Patch tools
The Healing Brush and Patch tools go one step beyond the capabilities of the Clone
Stamp and Spot Healing Brush tools. Using their ability to simultaneously apply and
blend pixels from area to area, they open the door to natural-looking touch-ups in areas
that are not uniform in color or texture.
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In this project, you’ll touch up the stone wall, removing some graffiti and bolt holes
left over from obsolete climbing techniques. Because the rock varies in color, texture,
and lighting, it would be challenging to successfully use the Clone Stamp tool to
touch up the damaged areas. Fortunately, the Healing Brush and Patch tools make this
process easy.
If you want to review the “before” and “after” versions of this image, use Adobe Bridge
as described in “Getting started” beginning on page.

Using the Healing Brush to remove ﬂaws
Your first goal for this image is to remove the initials that mar the natural beauty of the
rock wall.
1 Click the Go To Bridge button ( ) in the tool options bar, and in Bridge, doubleclick the 03B_Start.psd file to open it in Photoshop.
2 Choose File > Save As, rename the file 03B_Working.psd, and click Save to save the
original start file. Working on a version of the start file lets you return to the original at
any time.
3 In Photoshop, select the Zoom tool ( ) in the toolbox. Click the initials “DJ” that
have been scratched into the lower left area of the rock so that you see that area of the
image at about 200%.
4 In the toolbox, select the Healing Brush tool ( ), hidden under the Spot Healing
Brush tool.
5 In the tool options bar, open the Brush Preset pop-up palette, and decrease the
Diameter value to 10 pixels. Then, close the pop-up palette and make sure that the other
settings in the tool options bar are set to the default values: Normal in the Mode option,
Sampled in the Source option, and the Sample Aligned check box deselected.
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6 Hold down Alt (Windows) or Option (Mac OS) and click just above the scratched-in
graffiti in the image to sample that part of the rock. Then release the Alt/Option key.

7 Starting above the graffiti “D,” paint straight down over the top part of the letter,
using a short stroke.
Notice that as you paint, the area the brush covers temporarily looks as if it isn’t making
a good color match with the underlying image. However, when you release the mouse
button, the brush stroke blends in nicely with the rest of the rock surface.

8 Continue using short strokes to paint over the graffiti, starting at the top and moving
down until you can no longer detect the graffiti letters.
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When you finish removing the graffiti, look closely at the surface of the rock, and notice
that even the subtle striations in the stone appear to be fully restored and naturallooking in the image.

9 Zoom out to 100%, and choose File > Save.

About snapshots and History palette states
When you do retouching work, it can be easy to over-edit images until they no longer
look realistic. One of the safeguards you can take to save intermediate stages of your
work is to take Photoshop snapshots of the image at various points in your progress.
The History palette automatically records the actions you perform in a Photoshop file.
You can use the History palette states like a multiple Undo command to restore the
image to previous stages in your work. For example, to undo the most recent six actions,
simply click the sixth item above the current state in the History palette. To return to
the latest state, scroll back down the History palette and select the state in the lowest
position on the list.
The number of items saved in the History palette is determined by a Preferences setting.
The default specifies that only the 20 most recent actions are recorded. As you make
more changes to the image file, the earliest states are lost as the latest ones are added to
the History palette.
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When you select an earlier state in the History palette, the image window reverts to the
condition it had at that phase. All the subsequent actions still appear below it in the
palette. However, if you select an earlier state in your work and then make a new change,
all the states that appeared after the selected state are lost, replaced by the new state.
Snapshots let you try out different techniques and then choose among them. Typically,
you might take a snapshot at a stage of your work that you want to keep, at least as a base
point. Then, you could try out various techniques until you reach a possible completed
phase. If you take another snapshot at that phase, it will be saved for the duration of the
current work session on that file. Then, you can revert to the first snapshot and try out
different techniques and ideas for finishing the image. When you finish the image, you
could take a third snapshot, revert to the first snapshot, and try again.
Note: Saving many previous states and snapshots is RAM-intensive. It is not recommended
when you work with large or complex images, such as images with many layers, because it
can slow performance. If you often work with complicated images that require maximum
RAM, consider reducing the number of history states saved by changing that setting in
your Photoshop preferences.
When you finish experimenting, you can scroll to the top of the History palette to where
the snapshots are listed. Then, you can select each of the final snapshots in turn and
compare the results.
Once you identify the one you like best, you can select it, save your file, and close it.
At that time, your snapshots and History palette listings would be permanently lost.
Note: You can keep an Edit History Log on a Photoshop file. The Edit History Log is
a textual history of what has been done to the image file. For more information, see
Photoshop Help.

Taking a snapshot
Because you are satisfied with the results of your healing the graffiti marks, now
is a good time to take a snapshot. This will serve as a baseline for any future
experimentation during this work session. (Remember that snapshots and history
listings are discarded when you close a file.)
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1 Close the Navigator, Color, and Layer palette groups—you won’t use them in this
lesson—and use the space to expand the History palette so that you can see as many
items as possible. If necessary, scroll to the bottom of the History palette so that you can
see the last change you made to the image.

2 With the most recent state in the History palette selected, click the New Snapshot
button ( ) at the bottom of the History palette to create a snapshot of the current state.

3 Scroll to the top of the History palette. A new snapshot, Snapshot 1, appears at the
top of the palette.
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4 Double-click the words Snapshot 1, type Post-graffiti, and press Enter or Return to
rename the snapshot.
Note: You can also take snapshots of earlier phases of your current work session. To do this,
scroll to that item in the History palette, select it, and click the New Snapshot button at the
bottom of the palette. After you rename the snapshot, reselect the state at which you want
to continue working.
5 Make sure that either the Post-graffiti snapshot or the last state in the history list is
selected in the History palette. Then, choose File > Save.

Using the Patch tool
The Patch tool combines the selection behavior of the Lasso tool with the color-blending
properties of the Healing Brush tool. With the Patch tool, you can select an area that
you want to use as the source (area to be fixed) or destination (area used to do the
fixing). Then, you drag the Patch tool marquee to another part of the image. When you
release the mouse button, the Patch tool does its job. The marquee remains active over
the mended area, ready to be dragged again, either to another area that needs patching
(if the Destination option is selected) or to another sampling site (if the Source option
is selected).
It may be helpful to zoom in before you begin so that you can easily see the details of
the image.
1 In the toolbox, select the Patch tool ( ), hidden under the Healing Brush tool ( ).
2 In the tool options bar, make sure that Source is selected.
3 Drag the Patch tool pointer around a few of the bolt holes to the right of the climber,
as if you were using the Lasso tool, and then release the mouse button.
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4 Drag the selection to an unblemished area of the rock, preferably—but not
necessarily—one that is similar in color to the rock around the bolt holes.

As you drag, the original selected area shows the same pixels as the lassoed selection
you are dragging. When you release the mouse button, the color—but not the texture—
readjust to the original color scheme of the selection.
5 Drag a new selection around some of the other bolt holes and then drag to an
unblemished area of the image. Continue to patch the image until all the scars are
repaired to your satisfaction. (Be sure to patch the holes on the left side of the image.)
6 Choose Select > Deselect.
7 Choose File > Save.

Using the History Brush tool to selectively reedit
Even with the best tools, retouching photographs so that they look completely natural
is an art and requires some practice. Examine your rock-climber image critically to see
if any areas of your work with the Healing Brush or Patch tools are now too uniform
or smooth, so the area no longer looks realistic. If so, you can correct that now with
another tool.
The History Brush tool is similar to the Clone Stamp tool. The difference is that instead
of using a defined area of the image as the source (as the Clone Stamp tool does), the
History Brush tool uses a previous History palette state as the source.
The advantage of the History Brush tool is that you can restore limited areas of the
image. As a result, you can keep the successful retouching effects you’ve made to some
areas of the image and restore other, less successfully retouched areas to their previous
state so that you can make a second attempt.
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1 In the toolbox, select the History Brush tool ( ).
2 Scroll to the top of the History palette and click the empty box next to the Postgraffiti snapshot to set the source state that the History Brush tool will use to paint.
3 Drag the History Brush tool over the area where the bolt holes appeared before you
edited them, to start restoring that part of the image to its previous condition. The bolt
holes reappear as you paint.

4 Using the tool options bar, experiment with the different settings for the History
Brush tool, such as Opacity and Mode. Notice how these affect the appearance of the
rock as you paint.
If you don’t like the results of an experiment, choose Edit > Undo, or click an earlier
action at the bottom of the History palette to revert to that state.
5 Continue working with the History Brush and Patch tools until you are satisfied with
the final appearance of your image.
6 Choose File > Save, and then choose File > Close.
You’ve finished your work on this image.

Retouching on a separate layer
In the previous project, you safeguarded your retouching work by using snapshots
and the History Brush tool. Another way to protect your original image is to do your
retouching work on a duplicate layer of the original image. Then, you can retouch
the duplicate layer. When you finish retouching, you can blend the two layers. This
technique usually enhances the results, making your touch-up work look more natural
and realistic.
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Using the Healing Brush on a duplicate layer
For this project, you’ll work on a portrait photograph.
1 Choose Window > Workspace > Reset Palette Locations to move, reopen, and resize
any palette groups that you rearranged in the previous project.
2 Use the Go To Bridge button ( ) in the tool options bar, and double-click the
03C_Start.psd thumbnail to open the file in Photoshop.
3 Choose File > Save As, rename the file 03C_Working.psd, and click Save.
You’ll start by adding a duplicate layer for your retouching work.
4 In the Layers palette, hold down Alt (Windows) or Option (Mac OS) and drag the
Background layer onto the New Layer button ( ) at the bottom of the palette to display
the Duplicate Layer dialog box. Name the new layer Retouch, and press Enter or
Return. Leave the Retouch layer selected.

5 In the toolbox, select the Healing Brush tool ( ), which may be hidden under the
Patch tool ( ).
6 In the tool options bar, open the Brush Preset pop-up palette and set the brush
diameter to 12 pixels; then select the Sample Aligned check box. Leave the other settings
at their defaults (Normal selected as the Mode option and Sampled selected for Source).
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Notice the two wrinkles running horizontally across the man’s forehead. (Zoom in if
necessary by pressing Ctrl+spacebar (Windows) or Command+spacebar (Mac OS)
and clicking.)
7 Hold down Alt (Windows) or Option (Mac OS) and click a smooth area of the
forehead, on the left side of the image, to set the sample point. Then, drag the Healing
Brush tool over the lower of the two forehead wrinkles.

As you drag, the painted pixels don’t exactly match the subject’s natural skin tones.
When you release the mouse button, however, the colors self-correct so that the wrinkle
is covered and the skin looks quite natural.
8 Continue painting with the Healing Brush tool to remove the upper forehead wrinkle
and the furrow line between the eyebrows. You can toggle between history states in the
History palette to compare results.

9 Choose File > Save to save your work so far.
EXTRA CREDIT Try using the Spot Healing Brush on this image and compare
the results.
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Patching and softening using the separate layer
You’ll continue to do cosmetic work on the portrait image using the Patch tool and
the duplicate layer (Retouch) you created in the previous exercise. Make sure that the
Retouch layer is selected in the Layers palette before you begin.
1 In the toolbox, select the Patch tool ( ), hidden under the Healing Brush tool ( ).
Then, drag a marquee around the wrinkles under the subject’s right eye, outside
the eyeglasses.

2 Move the Patch tool inside the selected area and drag it to a smooth, similarly toned
area on the man’s forehead. Then, use the same technique to erase the wrinkles inside
the glasses under the right eye, and inside and outside the glasses under the left eye.
3 Continue to touch up the subject’s face with the Patch tool until most of the wrinkles
are hidden, or at least softened. When you have finished your touch-ups, if you zoomed
in, zoom out by pressing Alt+spacebar (Windows) or Option+spacebar (Mac OS)
and clicking.
It is especially important that cosmetic touch-ups on the human face look as natural as
possible. There’s an easy way to make sure that your corrections aren’t too smooth or
plastic looking. You’ll do that now.
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4 In the Layers palette, change the Opacity value of the Retouch layer to 65%. Now,
hints of the heaviest skin creases appear in the image, giving the enhanced image a
convincing realism.

5 Click the eye icon ( ) to toggle the Retouch layer off and on to see the difference
between the original image and the corrected one.
Look at the two numbers on the status bar, just to the right of the zoom percentage, at
the bottom of the image window. (If you don’t see two numbers, click the right-pointing
arrow and choose Show > Document Sizes.) The first number (ours is about 6.18 MB)
represents the size the file would be if the two layers were flattened into one layer. The
second number (ours is about 12.4 MB) shows the current size of the file with its two
layers. However, after you flatten the image, you cannot separate the two layers again.
When you are sure that you are satisfied with the results of your retouching efforts, it’s
smart to take advantage of the space-saving of flattening.
6 Choose Layer > Flatten Image, or choose Flatten Image from the Layers palette menu.
7 Choose File > Save.
Now the image has just one layer, combining the unaltered original background and the
partly transparent retouched layer.
Congratulations; you’ve finished your work on this lesson. Close any open files.

Chapter 3. Retouching and Repairing
Adobe® Photoshop® CS3 Classroom in a Book® By Adobe Creative Team ISBN:
Prepared for Hal Peterson, Safari ID: hal@halpeterson.com
9780321492029 Publisher: Adobe Press
Print Publication Date: 2007/04/16
User number: 1002568
© 2009 Safari Books Online, LLC. This PDF is made available for personal use only during the relevant subscription term, subject to the Safari Terms of Service. Any other use
requires prior written consent from the copyright owner. Unauthorized use, reproduction and/or distribution are strictly prohibited and violate applicable laws. All rights reserved.

Chapter 3. Retouching and Repairing

Page 20

Return to Table of Contents

Review
Review questions
1 Describe the similarities and differences of the Clone Stamp tool, the Spot
Healing Brush tool, the Healing Brush tool, the Patch tool, and the History
Brush tool.
2 What is a snapshot and how is it useful?

Review answers
1 As you paint with the Clone Stamp tool, it duplicates the pixels from another
area of the image. You set the sample area by holding down Alt (Windows) or
Option (Mac OS) and clicking the Clone Stamp tool.
The Spot Healing Brush tool removes blemishes and imperfections from a
photograph. It paints with automatically sampled pixels from an image or pattern,
matching the texture, lighting, transparency, and shading to the pixels being healed.
The Healing Brush tool works like the Clone Stamp tool except that Photoshop
calculates a blending of the sample pixels and the painting area so that the
restoration is especially subtle, yet effective.
The Patch tool works like the Healing Brush tool but instead of using brush
strokes to paint from a designated area, you drag a marquee around the area to be
fixed and then drag the marquee over another area to mend the flawed area.
The History Brush tool works like the Clone Stamp tool except that it paints pixels
from a designated previous state or snapshot that you select in the History palette.
2 A snapshot is a temporary record of a specific stage in your work session. The
History palette saves only a limited number of actions. After that, each new action
you perform removes the earliest item from the History palette list. However, if
you select any action listed in the History palette and take a snapshot of that state,
you can continue working from that action or another one. Later in your work
session, you can revert to the state recorded by the snapshot by selecting it in the
History palette, regardless of how many changes you’ve made in the meantime.
You can save as many snapshots as you please.
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